Linux problem

Status
Not open for further replies.

baby_mike

Est. Contributor
Messages
1,481
Role
  1. Adult Baby
  2. Diaper Lover
  3. Sissy
  4. Other
Ok i just got a laptop and i installed Ubuntu on it. When I tryed to install Flash Player I get an error.

 
Last edited:

mm3

Est. Contributor
Messages
1,795
Role
  1. Carer
  2. Other
You'll want to do this instead;

$ sudo apt-get install flashplugin-nonfree

You may have to enable mutliverse in /etc/apt/sources.list though to do so.

You can do that by doing $ sudo nano /etc/apt/sources.list -- and then uncommenting the commented lines that look like "# deb ___ ___" to look like "deb ___ ___"
 

baby_mike

Est. Contributor
Messages
1,481
Role
  1. Adult Baby
  2. Diaper Lover
  3. Sissy
  4. Other
I'm a retard when it comes to linux. What did you just say?
 

mm3

Est. Contributor
Messages
1,795
Role
  1. Carer
  2. Other
System --> Administration --> Software Sources

Go through the first two tabs and make sure all check boxes (excluding Source Code) is checked. Then, press okay, and "Reload" when it asks you to.

Then open up a terminal, and do "sudo apt-get install flashplugin-nonfree"

Restart Firefox, and thar you go.
 

baby_mike

Est. Contributor
Messages
1,481
Role
  1. Adult Baby
  2. Diaper Lover
  3. Sissy
  4. Other
Ok I will try that once Ubuntu is done doing an udate
 

DannyTheNinja

Banned
Messages
852
Role
  1. Private
Just a quick note - it might be slightly trickier if you're running 64-bit Ubuntu. I've had quite a few woes of my own with 64-bit Flash and Linux. At present, Adobe's 64-bit native plugin is working fine for me on my desktop (a Phenom II X4) but their badly configured compiler settings resulted in a few nice Firefox crashes before I actually disassembled the thing and found out that the Athlon 64 chip in the kitchen computer wasn't supporting a few SSE2 instructions that the plugin used despite supposedly including SSE2. I had a lot of crashes with the nspluginwrapper setup installable via Apt too. It only worked for me when I manually built nspluginwrapper and installed 32-bit Flash myself.

If you're on 32-bit Ubuntu or nspluginwrapper hasn't crashed Firefox yet, then smile and disregard this, because you've dodged the hell on earth that is Flash on Linux. :)

--Danny :ninja:
 

baby_mike

Est. Contributor
Messages
1,481
Role
  1. Adult Baby
  2. Diaper Lover
  3. Sissy
  4. Other
Im running a 32bit pc. When Ubuntu did an update it seemed to fix the problem
 

tenlet

Est. Contributor
Messages
202
Role
  1. Diaper Lover
  2. Little
Just a quick note - it might be slightly trickier if you're running 64-bit Ubuntu. I've had quite a few woes of my own with 64-bit Flash and Linux. At present, Adobe's 64-bit native plugin is working fine for me on my desktop (a Phenom II X4) but their badly configured compiler settings resulted in a few nice Firefox crashes before I actually disassembled the thing and found out that the Athlon 64 chip in the kitchen computer wasn't supporting a few SSE2 instructions that the plugin used despite supposedly including SSE2. I had a lot of crashes with the nspluginwrapper setup installable via Apt too. It only worked for me when I manually built nspluginwrapper and installed 32-bit Flash myself.

If you're on 32-bit Ubuntu or nspluginwrapper hasn't crashed Firefox yet, then smile and disregard this, because you've dodged the hell on earth that is Flash on Linux. :)

--Danny :ninja:
I don't think I've been having the same problems as you, but flash doesn't work well on my 64-bit machine. Right now I'm using a Greasemonkey script I found that lets me play youtube videos as mpeg's. For non-video flash, it works or I get by without it. Personally, I'm hoping JavaScript and the <video> tag take over, as they will probably work better on Linux.
 
Last edited:

mm3

Est. Contributor
Messages
1,795
Role
  1. Carer
  2. Other
You drag and drop the tar.gz into System --> Preferences --> Appearance (The theme tab).

It'll automatically install it for you.
 
Status
Not open for further replies.
Top