Results 1 to 3 of 3

Thread: [HELP] Wireless Adapter Not Working

  1. #1

    Default [HELP] Wireless Adapter Not Working

    Note: Downgrading to Windows 8/8.1 or 7 is not an option, nor is using an ethernet connection instead of wi-fi. Please don't recommend either, I have my reasons.

    I can't get Windows 10 to recognize/show my wireless adapter, no matter what I've done. Already tried disabling all other network adapters first before installing the latest driver from their website, and then rebooting, nothing happened. I've also tried going thru device manager and updating it that way, won't even let me update and it can't find drivers automatically.

    Please can someone here help me figure out what the problem is with my wireless adapter and make it work/show up on my computer?

    My PC's Specs
    OS: Windows 10 Home Full 64-bit
    CPU: AMD A10-7890K 4.1GHz Quad-Core Processor
    RAM: Corsair Vengeance Pro 16GB (2 x 8GB) DDR3-2133 Memory
    Motherboard: Gigabyte GA-F2A88X-D3HP ATX FM2+ Motherboard
    Graphics/Video: AMD Radeon R7 Graphics (Integrated)
    Boot SSD: Samsung 850 EVO-Series 500GB 2.5" Solid State Drive
    Storage HDD: Western Digital Caviar Black 4TB 3.5" 7200RPM Internal Hard Drive
    Audio: AMD High Definition Audio Device (Integrated)
    Case: Cooler Master MasterCase Pro 5 ATX Mid Tower Case
    Power Supply: EVGA SuperNOVA G3 750W 80+ Gold Certified Fully-Modular ATX Power Supply
    Wireless Adapter: TP-Link Archer T9E PCI-Express x1 802.11a/b/g/n/ac Wi-Fi Adapter
    Monitor: Dell SE2416H 23.8" 1920x1080 60Hz Monitor
    Keyboard/Mouse: Logitech - MK345 Wireless Standard Keyboard w/Optical Mouse

    Speccy Info:
    http://i.imgur.com/YRDkB1N.png

  2. #2

    Default

    Hmm... Sounds like there are problems with the driver in Windows 10 64-bit machines.

    The official specs say they only support "Windows 8.1/8/7/XP":
    http://static.tp-link.com/resources/..._Datasheet.pdf

    And it sounds like a lot of people have had problems getting the drivers running on Win10 x64 with similar wireless adapter models:
    http://forum.tp-link.com/showthread....ith-Windows-10

    I'm not sure if this links to a driver you have already tried, but you could try the relevant one here:
    http://www.tp-link.com/us/win10compatibility.html

  3. #3

    Default

    Thanks for trying to help me out. Turns out I was trying to install the wrong version this entire time XD.

    My wi-fi is now working and this can be considered closed/resolved.

Similar Threads

  1. Adapter for wide-neck bottles?
    By Paxy in forum Adult Babies & Littles
    Replies: 0
    Last Post: 22-Aug-2013, 23:59
  2. Do I need a new wireless router?
    By Point in forum Computers & Gaming
    Replies: 8
    Last Post: 22-Sep-2009, 22:05
  3. using multiple wireless points at once?
    By kite in forum Computers & Gaming
    Replies: 11
    Last Post: 15-Oct-2008, 22:23
  4. Using a wireless internet service
    By tom in forum Computers & Gaming
    Replies: 12
    Last Post: 27-Jun-2008, 14:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
ADISC.org - the Adult Baby / Diaper Lover / Incontinence Support Community.
ADISC.org is designed to be viewed in Firefox, with a resolution of at least 1280 x 1024.